A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 15:42 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2026 - 15:07 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2026 - 14:38 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2026 - 13:28 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 26, 2026 - 12:48 EDT
Update
We are continuing to investigate delays in monitor notifications.
Posted Mar 26, 2026 - 12:11 EDT
Update
We are still continuing investigating delays in monitor notifications that started at 12:00 UTC. We've identified the root cause and are working on a fix.
Posted Mar 26, 2026 - 11:32 EDT
Update
We are continuing investigating delays in monitor notifications that started at 12:00 UTC.
Posted Mar 26, 2026 - 10:55 EDT
Investigating
We are investigating delays in monitor notifications, which began at 12:00 UTC.